Frequently Asked Questions

Help Topics

I'm getting an error from the Google Play Store saying my device is not compatible with the version of the app. What do I do?

Our app is compatible with any phone which is running Android 4.4 (KitKat) or later. We've heard from some customers that the Google Play Store is reporting that our app is not compatible. In order to install the app on your phone, you should connect your phone to a PC/Mac and access the Google Play website in your browser. Then choose Android apps from the "Shop" drop down in the upper left corner. You should then be taken to the Android app store, where you can search for the Clydesdale Bank app. On the apps page, near the left margin, click the Install button. Then you will be presented with some information about the app chosen to install, including app permissions, and a drop-down to select which device to install it onto. To start the install click on continue.

If you're not able to connect to a PC/Mac, it may be possible to solve the problem by reverting to a previous version of the Play Store. Remember, most of the time, it's important to use the most up-to-date versions for better security.

Feedback

We value your feedback. Did you find this article useful?