Frequently Asked Questions

Help Topics

I can't update my iOS app, what should I do?

If you are an iOS user and you cannot update your app, it may be because your device is not compatible with version 2.18 or later of the app.

If your device is on the list of incompatible devices. you will no longer be able to use the mobile app. However, you can still do your banking on your device, by logging in on a browser to Clydesdale Internet Banking.

If you are still having problems, please call us on 0800 456 1247. We're here 24hrs a day for further information.

Feedback

We value your feedback. Did you find this article useful?